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Sibelius Tools For Bagpipe Musical Notation 
Bob Zawalich,  January 17, 2011 

 

Is Sibelius the appropriate tool for Bagpipe notation? 
 
Bagpipe music notation has a number of quirks, not the least of which is the need to enter large 
numbers of grace note ornaments. Sibelius is not optimized for doing this, and it may be worth 
looking into notation programs that target bagpipe music specifically.  These include Bagpipe Music 
Writer, PiobMaster, and CelticPipes, and you may find that using one of these will give you an easier 
process than using Sibelius. 
 
Sibelius, however, is a very powerful and flexible piece of software, capable of generating truly 
publication quality scores, and also capable of realistic playback, and its features may well be useful 
enough to justify some extra work to make it handle pipe music. 
 
I developed some tools with pipers Janette Montague and Jim McGillivray to make it easier to 
produce music for the Scottish bagpipes in Sibelius (version 6 and later). 
 
There are a number of problems associated with producing scores for Scottish Great Highland Pipes, 
and here are some ways we came up with to solve them, or at least minimize their effects. 
 
These tools require Sibelius version 6 or later. 
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Major Tools 
There are 2 plugins that I consider to be the most useful of the tools described here: Add Pipe 
Ornament 2 and Play Pipe Ornaments.  

 
• Add Pipe Ornament 2 lets you add multi-note grace note 

ornaments with single keystrokes. To use it, you first 
enter all the "normal" (non-grace) notes, and then select 
those notes and run the plugin. It sets up a process where 
the plugin moves from note to note, and you type a key 
(0-9 or a-z) to insert a named ornament from the list in 
front of the selected note. You can skip over notes, and 
back up if you have made a mistake. There is a larger list 
of available ornaments, beyond the 36 on the dialog, 
accessible through the List button, and you can change 
which ornaments are mapped to the keys using the 
Options button, so if you commonly use an ornament not 
on the main list, you can replace a lesser user ornament 
with the one you use. 

 
• Add Pipe Ornament also adds grace note ornaments, but 

you have to run the plugin for each ornament you want to 
enter, and it can be less convenient. It does allow you to 
define your own new ornaments, however, which could be 
useful, and you can assign a keyboard shortcut to the 
plugin so you can bring it up more easily. 

 
• For playback, Play Pipe Ornaments analyzes a number of 

common ornaments, and sets the Live Playback data for 
the grace notes so the start position and duration is close 
to the desired timing. Some experimentation will be 
required to find the most desirable timing, and the results 
may only be useful for aural proofreading, but the results 
are definitely better than what you get using Sibelius 

alone. 
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Other Notation issues 

Dealing with C# as C and F# as F 
 
Traditionally, this music is notated with no key signature, with no accidentals for C's and F's (It is 
written as if in A Aeolian mode, but sounds as if in Bb Mixolydian). You can have a score in C major 
and enter the C's and F's as naturals if you are not concerned with playback. But if you want the 
program to play back at all, the C's should be entered as C#'s and the F's as F#'s. 
 
One common approach is to enter the music as if in the key of D major. This hides the accidentals in C 
and F and playback works (though it should really play back a half-step higher, as addressed below). 
You will then need to hide the key signature, so it will really look as though it were notated in the key 
of C (see Hiding the Key Signature, below). 
 
Another approach is to write the music in C major (so there  is no key signature), entering C# and F# 
explicitly with accidentals, and then hide any accidentals on the C's and F's by defining a notehead 
style based on normal noteheads, but not showing accidentals. Use House Styles > Edit Noteheads for 
this, and make a new notehead style based on normal notes. 
 

 
 
Apply this notehead style to all entered notes in the bagpipe by selecting the notes and using the 
noteheads dropdown on the Notes pane of the Properties window. The notehead definition will only 
appear in the score where it is defined unless you use House Styles > Export House Style to export a 
house style, and then use House Styles > Import House Style to import it into other scores, including 
Manuscript Papers. 
 
 



 4 

 
 
This works, but it is a bit tedious to enter the accidentals for the C's and F's. 
 
A variant of this is to use the same notehead style that has no accidentals, and enter all the notes in 
the key of D major (while the key signature is visible). There is an option in House Styles > Edit 
Instruments > Edit Staff Type > General > Other Objects to turn off "Key Signature/Tuning". If you 
do this after entering the notes, it will hide the key signature, and the notehead style will hide the 
accidentals. Don't start with an instrument with no key signature, though, or C's and F's will be 
entered as naturals. 
 

Hiding the key signature 
 
Sibelius does not make it easy to have music be in a specific key other than C major/A minor, but 
show no key signature.  
 
The option in House Styles > Edit Instruments > Edit Staff Type > General > Other Objects to turn off 
"Key Signature/Tuning" will make any accidentals appear in the score, as if you had chosen the key of 
C major or the atonal key. 
 
You can use the Bar pane in the Properties window to hide the key signature in a specific bar, which 
will accomplish what is needed. Select each bar that displays a key signature (usually the ones at the 
start of a system), and uncheck the Key Signature box in the Bar pane. 
 

 



 5 

 
This can be tedious, as selecting several bars at once disables the Bar pane. Here is a trick I learned 
from music editor Jeremy Hughes: if a bar has a bar number, you can filter the bar numbers and then 
all the filtered bars can be changed at once in the Bar pane. 
 
So if you are showing bar numbers at the start of each system, you can just go to Edit > Filter Bar 
Numbers, and then use the Bar pane. 
 
If you are not showing bar numbers, you can go to House Styles > Engraving Rules > Bar Numbers 
and tell it to show bar numbers at the start of each system (or even every bar), then do the filter and 
hide the signatures, and then go back to Engraving Rules and turn off the bar numbers. I like to turn 
the property off for all the bars, because if you only do the first bars in a system and then reformat the 
score, you may get key signatures from the shifted bars. If this happens, repeat the process of hiding 
the key signatures. 
 
How do you tell what the key signature is for the score? If you get a score like this, it can be puzzling, 
because it looks as though the score is in C major, but the playback suggests something different. 
There is nothing in Sibelius that explicitly tells you the key (normally you just look at the key 
signature), but here are 2 ways to see the signature. The first is to select the first bar and look in the 
properties Window Bar pane. If "Key signature" is unchecked, check it and you should see the key 
signature. (Don't forget to turn it back off). The other way is to select a bar and choose Notes > 
Transpose. Look at the "By key" options, which will show the current *sounding* key. This can give 
tricky results if you have a transposing bagpipe in a transposing score, so the written pitches are in D, 
but the sounding pitches are Eb, as in the example below. 
 
 

 
 
If you have multiple non-pipe instruments in a score, hiding the key signature in this way will hide it 
for all the instruments, which is probably not what you want. So in that case, either show the key 
signature for all the instruments, or you can go to any parts which are only bagpipes, and hide the key 
signatures in the parts. That way, if you give the piper just the part, it will not have the key signatures. 
 

Notation where there are non-pipe instruments in the score (using a 
bagpipe as a transposing instrument) 
 
If there are other instruments in the score, they should be notated in the keys in which they sound, 
which is normally Eb. So the problem is what to do with the pipes. 
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One reasonable solution is to create a "transposing" bagpipe instrument that works like a saxophone 
or clarinet (among many transposing instruments). These instruments appear as they will sound 
in the concert score (in this case in the key of Eb major), and appear as the player wants to see 
them (in D major/ A mixolydian) in a transposing score or a part.   
 

 
 
Example of transposing bagpipe. On the left, in the full concert score, the bagpipe appears in Eb 
major, as the other instruments do. But in the bagpipe part (in yellow, on the right), the music 
appears to be in the key of D major.(Score example courtesy of Janette Montague). 
 
To create such an instrument, use House Styles > Edit Instrument, select a bagpipe instrument and 
choose New to make a new instrument derived from a bagpipe. Under Transposition change C4 to 
sound as Db4. Now create an instrument using this style, or use Create > Instrument Change to 
change an existing instrument. (Note that if you are notating in C rather than in D, a transposing 
bagpipe will have to change C4 to sound as Eb4. A number of the tools in this collection may not work 
for you, since they assume you are notating in the key of D) 
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If you do this, and want to enter the notes as if they are in the key of D, enter the pipe notes in the 
transposing score (where the key signature will appear as D major). If you enter notes in the 
concert score, you will need to enter the notes in Eb. 
 
If you give such a score to players, either just give the parts, or warn them to look only at the 
transposing score. Change to the transposing score by clicking on the "flats" button in the toolbar. 
 

 
 
You might decide to use a transposing instrument even if you have a solo bagpipe, since this solves the 
problem of having to raise the pitch from the key of D to Eb for playback. It adds the possibility of 
confusion, though, if a piper sees the concert score, or if you accidentally add notes in D when the 
staff is in Eb. If you are careful, though, it can work really well, and it is really the only practical 
solution when you have multiple instruments in a score. 
 
The included House Styles and Manuscript Papers include definitions for transposing bagpipe 
instruments. 
 

Using the Bagpipe Plugins with Transposing Bagpipe Instruments 
The plugins always deal with the written pitches low G to high A, and they needed to be adapted to handle 
transposing instruments.  This is what the plugins do, just so you won't be surprised: 
 
Trace Pipe Ornaments will change the score to Transposing view while it generates the trace, and will restore 
the view at the end. If the score had been in Concert view, and the pitches were a semitone higher, the traced 
ornaments will have the correct names, but the pitches will be what the Transposed score would show (for 
example, D rather than Eb). 
 
The Add Pipe Ornaments plugins will determine whether the bagpipe instruments are transposing, and whether 
the score is in Concert view. If that is the case, it will offer to change to Transposing view or cancel the plugin. 
 
Bagpipe Drone offers drones in A for non transposing instruments, or Bb for transposing instruments. You need 
to decide which option is appropriate. For a transposing instrument, use the Bb drones regardless of whether the 
score is in Transposing or Concert View.  
 
Similarly, if you and using Bagpipe Drone and have non transposing instruments and plan to use the Export 
Bagpipe Audio plugin, you should use the Bb drones before running the plugin (though you might want the A 
drones for normal playback. You can rerun Bagpipe Drone and it will replace existing drone text, but this 
combination of plugins is a bit messy, since the Drone MIDI text does not transpose. 
 

Stems down 
 
Traditionally in pipe music, non grace notes have stems pointing down, and grace notes have their 
stems pointing up. 
 
The standard bagpipe instrument in Sibelius will have stems down for non grace notes on the middle 
staff line or above, and stems up otherwise. 
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What people usually do is enter the notes however they go in, and then select any notes with stems up 
and use X to flip the stems. This certainly works but it is easy to miss a few notes. 
 
There is another approach, but it requires some changes to your input process, and some extra steps 
to remember. But here is a method which uses Sibelius's ability to define a staff whose note stems 
always point up or always point down: 
 
You can change the way stems point in House Styles > Edit Instruments (Bagpipe) > Edit > Edit Staff 
Type > Notes and Rests, so they are always down. 
 

 
 
Ideally, this would be all you would have to do. Unfortunately, if you do this and have any dotted 
notes on staff lines, the dots appear below the staff line, when they really should go above the line. 
However, if you choose a staff type that is always up, then select all the notes and flip them, the dots 
will be in the correct place. 
 
We can take advantage of that. 
 
The included Manuscript Papers and House Styles have some instrument definitions that use the 
always up and always down properties. One way to use them is to start a score with instruments that 
are always stems down, and ignore the fact that any dots are in the wrong place. Enter all your notes, 
and things will mostly look OK, and then you can run the plugin Bagpipe Notation Repair. This has 
an option that will change the selected bagpipe instruments to use the style Bagpipe Stems Up, and it 
will then flip the non-grace notes, so the dots will be in the right place.  
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If you start with a Stems Down instrument, be sure to run the plugin at the end, or your rhythm dots 
will be wrong. 
 

 
 

Other Plugins to aid in notation 
 
Notation from Live Playback is a proofreading plugin. I have used it after running Play Pipe 
Ornaments. It adds a staff filled with notes derived from the live playback data. So it provides a way of 
seeing "what the sound looks like". 
 
Trace Pipe Ornaments is another proofreading plugin. It creates a list of the ornaments it finds in the 
score with their names and location in the score. It is handy for someone like me who is not familiar 
with the ornaments, and can also be used to catch note misspellings after a score is completed. 
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Playback issues 
 
There are 4 main classes of issues here.  
 
The first is that grace notes as played back in Sibelius do not start and end where they should for pipe 
music, and we would like more control over the duration of grace notes, which are typically notated as 
32nd notes, but should play back as shorter durations. 
 
The second is that pipe music notated in D major should play back as if notated in Eb major, that is, 
one major second/semitone higher. 
 
The third is that there should be a continuous drone when pipe music is playing. 
 
The fourth is that it is desirable to have a good bagpipe instrument sound. 
 
One solution for the second, third and fourth problem is to acquire a sound library that is set up to 
work with pipes. Some of these have the ability to toggle a drone on and off, and also the ability to 
transpose the output in playback, so that music can be notated as if in D major and sound as if in Eb 
major. This will be discussed below. 

Correct timing of playback for grace note ornaments/ornaments 
 
One of our original goals was to make pipe ornaments play back correctly. We put in a considerable 
amount of effort to be able to specify the start time and duration of grace notes in pipe 
ornaments/embellishments, and the plugin Play Pipe Ornaments is the primary result of that work. It 
analyzes a number of common ornaments, and sets the Live Playback data for the grace notes so they 
sound at least closer to the desired timing. Some experimentation will be required to find the most 
desirable timing, and the results may not be good enough for anything but aural proofreading, but the 
results are definitely better than what you get using Sibelius alone. 
 

Bagpipe Sound Libraries 
 
The standard Sibelius libraries are not particularly bagpipe friendly. Sibelius Essentials substitutes a 
clarinet for the bagpipe sound. I suggest using the General MIDI (Enhanced) playback configuration 
if you have no better library. It has a bagpipe sound, and it is a sound library that can use File > 
Export >Audio, so you can record the output of scores to audio files. 
 
There are some libraries designed specifically for bagpipes, and some general sound libraries that 
have pipe samples. Some of these have options to transpose the notation up by a semitone. 
 
We tried several of these but never ended up with any that worked for us. 
 
This is what we tried: 

Pipes only libraries  
 
Universal Piper (Mac and Windows) 
Studio Pipes (Windows only) 
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General sound libraries 
 
These are fairly expensive if you are only using them for the bagpipe sounds, but they can be useful if 
you need sound libraries for orchestral or other kinds of music (or you already have them). 
 
Kontakt 4 (note that there is a free player (Factory selection) that includes Uilleann Pipes, but not the 
Highland Pipes. The full Kontakt 4 library includes Uilleann Pipes, Highland Pipes and Tulum. If you 
have Sibelius 6, you can get a crossgrade to The Kontakt 4 Factory Library. See  
http://www.native-instruments.com/#/en/products/producer/kontakt-4/?page=1140 
 
EastWest RA  rare and ethnic instruments. See: 
http://www.eastwestsamples.com/details.php?cd_index=962 
 
 

Playback where D should sound as Eb (or C should sound as Eb) 
 
Bagpipe only scores 
 
There are at least 2 ways to deal with this. If your score only includes bagpipes and they are 
notated in the key of D, you can just play them back in D, which is probably OK as long as a piper does 
not want to play along with the score. 
 
To get playback in Eb when the score is written in D, you can 
 

• Use a sound library that allows you to transpose an individual instrument by a semitone. All 
who play the score will need to have a transposing library for this to work. 

• Create audio scores (Export > Audio) and transpose up a semitone before writing the audio 
score. The plugin Export Bagpipe Audio will transpose, write out an audio file, and transpose 
back. 

 
You can also use the transposing instruments described above, which will play back in Eb and display 
in D in the transposing score and parts. 
 
If you decided to notate in C rather than D, then adjust the descriptions accordingly. For a 
transposing bagpipe, C4 should sound as Eb4, and Export Bagpipe Audio will not work, so you will 
have to transpose by hand up a minor 3rd, and then export as audio. Most of the tools were developed 
for people notating in D. 
 
Scores with instruments other than bagpipes 
 
If there are other instruments in the score, they should be notated in the keys in which they sound, 
which is normally Eb. So the problem is what to do with the pipes. 
 
Probably the best solution is to create a "transposing" bagpipe instrument that works like a saxophone 
or clarinet (among many transposing instruments). These instruments appear as they will sound in 
the concert score, and appear as the player wants to see them in a transposing score or a part.  This is 
discussed above in the section on notating multiple instruments. 
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If you do this, and want to enter the notes as if they are in the key of D, enter the pipe notes in the 
transposing score (where the key signature will appear as D major). If you enter notes in the concert 
score, you will need to enter the notes in Eb. 
 
If you give such a score to players, either just give the parts or tell them to use the transposing score 
(this is less of a problem if you distribute written parts than if you distribute the Sibelius score file). 
 

Drones 
The plugin Bagpipe Drone adds some MIDI Note On messages to a score that will produce the A  (or 
Bb) drone notes without having to significantly modify the notation. 
 
You can also create a hidden staff that just contains tied drone notes. The are some problems with 
playback of long strings of tied notes, and if you have a long score you may find this to be a problem. 
The MIDI messages solution avoids this and is less disruptive to the score. 
 
This plugin is not needed if you have a sound library that can produce drones. We were not able to get 
any such library working in the time we worked on this project. 
 

Making audio recordings 
 
If your playback configuration (in Play > Playback devices) uses "virtual instruments", then you can 
make recordings using File > Export > Audio. Most playback configurations other than General MIDI 
(basic) will use virtual instruments. 
 
Export Audio will produce .wav files in Windows or .aiff files in OSX. If you want .mp3 files, you need 
to convert the .wav or .aiff files. I use the free Audacity program to do this; I understand that iTunes 
can also do this. 
 
The plugin Export Bagpipe Audio will transpose a score up a semitone and use File >Export > Audio 
on the transposed score. You will need to create mp3 files as a separate step. 
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More Plugins 
 
Resize Bar is not bagpipe-specific, but it is useful for creating variable size bars for pickups and 
shortened bars at the end of a tune section, which is common in bagpipe music. If you add the pickup 
notes to the left side of a full-size bar, and run Resize Bar with the Shrink bar to fit contents option, 
the bar will be easily resized to the pickup notes. Resize Bar is not included in the zip file, but can be 
downloaded for free from www.sibelius.com/download/plugins/index.html?plugin=238. 
 

 
 

House styles 
 
Bagpipes Landscape and Bagpipes Portrait contain several instrument definitions: 
 

Bagpipes Stems Down (change names, staff type stems down) 
Bagpipes Stems Up (change names, staff type stems up) 
Bagpipes Transposing Stems Down (change names, staff type stems down, transpose from D to 
Eb) 
Bagpipes Transposing Stems Up (change names, staff type stems up, transpose fro D to Eb) 
 
 

The instrument definitions are also used in the manuscript papers to allow various transposing 
bagpipe instruments and to give an effective mechanism to get the main notes to have stems facing 
down but have rhythm dots be above the staff lines the notes are on. 
 
The House Styles were also modified to prevent the instrument names from showing (as set in House 
Styles > Engraving Rules > Instruments), so the actual names of the instruments do not need to be 
deleted. 
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The manuscript papers were all set up using these House Style. 

Manuscript Papers 
 
These are the manuscript papers included: 
 
Bagpipe Landscape Down 
Bagpipe Landscape Up Down 
 
Bagpipe Landscape Transpose Down 
Bagpipe Landscape Transpose Up Down 
Bagpipe Landscape KS Transpose Down (key signatures are shown in bagpipe instrument) 
Bagpipe Landscape KS Transpose Up Down 
 
 
Bagpipe Portrait Down 
Bagpipe Portrait Up Down 
 
Bagpipe Portrait Transpose Down 
Bagpipe Portrait Transpose Up Down 
Bagpipe Portrait KS Transpose Down 
Bagpipe Portrait KS Transpose Up Down 
 
 
There are Landscape and Portrait papers. There are also papers that have default note stem direction 
set up in different ways, and ones that support transposing instruments (only for D to Eb, not for C to 
Eb). 
 
The manuscript papers were set up to deal with some common problems. 
 

1. We wanted to deal with common bagpipe setup issues. So the scores are set up to be in the key 
of D major, but the key signatures are hidden. 

2. We wanted to find a way to have the main note stems point down, with the rhythm dots 
appearing about the staff line the notes were on, while the grace notes stems pointed up. 

 
For each variation of manuscript papers (Portrait, Landscape,  Transposing, KS transposing) there are 
2 variants: 
 

• Up Down has stems that point down for notes on the middle staff line or above, which is the 
normal Sibelius default. 

• Down has stems that always point down. 
 
The use of these variants is discussed above, under Stems Down. 
 
The manuscript papers (other than the ones marked KS Transposing) are set up so all the initial bars 
have the Key Signature property turned off. If you add new bars, you may need to go to the Properties 
Window Bar pane and uncheck the Key Signature box. 
 
Transposing Manuscript Papers 
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The manuscript papers marked Transposing or KS Transposing are set to use transposing bagpipe 
instruments, which appear in the key of Eb in the concert score and D in the transposing score. The 
ones marked KS show the key signature, and are intended for scores to which other instruments will 
be added. The non KS papers are for solo bagpipes that use transposing instruments but do not show 
key signatures. 
 
These scores are in the concert key of Eb major, rather than D as the other papers are, and they start 
out as transposing scores. If you enter notes into the transposing score, you should enter the notes as 
if you were in the key of D major. This might require a bit of thinking before you start… 
 

Installation 
 
House styles, Manuscript Papers and Plugins should all be copied to subfolders of the Sibelius 6 user 
folder.  The root of this folder differs by Operating system: 
 
Windows XP: C:\Documents and Settings\username\Application Data\Sibelius 
Software\Sibelius 6\ 
Window Vista and Windows 7: C:\Users\username\AppData\Roaming\ Sibelius 
Software\Sibelius 6\ 
OSX: /Users/username/Library/Application Support/Sibelius Software/Sibelius 6/ 
 
You will need to create the subfolders House Styles, Manuscript paper, and Plugins if they do not 
exist. 
 
Copy the .lib files into the House Styles folder, the .sib files to Manuscript paper, and the .plg files to 
Plugins. Restart Sibelius after you copy the files so Sibelius can read them. 
 
My Windows 7 folders look like this: 
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Using the plugins 
Add Pipe Ornament 2 

 
• Add Pipe Ornament 2 lets you add multi-note grace note 

ornaments with single keystrokes. To use it, you first 
enter all the "normal" (non-grace) notes, and then select 
those notes and run the plugin. It sets up a process where 
the plugin moves from note to note, and you type a key 
(0-9 or a-z) to insert a named ornament from the list in 
front of the selected note. You can skip over notes, and 
back up if you have made a mistake. There is a larger list 
of available ornaments, beyond the 36 on the dialog, 
accessible through the List button, and you can change 
which ornaments are mapped to the keys using the 
Options button, so if you commonly use an ornament not 
on the main list, you can replace a lesser user ornament 
with the one you use. 
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Add Pipe Ornament  
 
 
 
 
 

• Add bagpipe grace note ornaments 
before a selected note. Choose a 
named ornament from a list 
(Doublings, Embellishments, 
Piobaireachd, Grace Notes, Custom) 
or customize your own ornaments. 
Customized ornaments are saved 
across Sibelius sessions. 

 
• You will run this plugin again each 

time you need to insert an ornament. 
It is probably useful to assign a 
keyboard shortcut, and it is probably 
most efficient to enter all ornaments 
of a given type, then all the 
examples of another ornament, so 
you do not have to keep selecting a 
new ornament each time the plugin 
runs. 
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Play Pipe Ornaments  
 

 
 
 
Play Pipe Ornaments analyzes a number of common ornaments, and sets the Live Playback data for 
the grace notes so the start position and duration is close to the desired timing. Some experimentation 
will be required to find the most desirable timing, and the results may only be useful for aural 
proofreading, but the results are definitely better than what you get using Sibelius alone. 
 
Choose a duration to represent the time spent by a note that is notated as a 32nd note. If it really took 
up a 32nd note duration, there would be no time for most real notes to be played! The default is 8/256 
of a quarter note, which is equivalent to a 128th note. So double it to 16 for a 64th note, and so on. You 
can edit the descriptions and timing of the ornaments, and create new ornament descriptions. Follow 
the instructions in the edit dialog. If you want the ornament to start before the beat of the following 
note, tell it how many notes in the ornament should play before the beat. 
 
In the descriptions in the dialog above, you will see 2 numbers following the description. The first is 
the number of pitches in the ornament, and it is added automatically by the plugin. You can edit the 
name, pitches, and the final number, which is the number of pitches before the beat. 
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Notation from Live Playback is a proofreading plugin. I have used it after running Play Pipe 
Ornaments. It adds a staff filled with notes derived from the live playback data. So it provides a way of 
seeing "what the sound looks like". Select the notes you want to analyze, and the plugin will add a new 
staff with those notes. It is best to run on a copy of the score, or to run it on a saved score, so you can 
close without saving after seeing what you want to see. 
 

 
 
Trace Pipe Ornaments is another proofreading plugin. It creates a list of the ornaments it finds in the 
score with their names and location in the score. It is handy for someone like me who is not familiar 
with the ornaments, and can also be used to catch note misspellings after a score is completed. Select 
some notes, run the plugin, and see the results in the trace window. 
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Bagpipe Drone 
 
Bagpipe Drone adds some MIDI Note On messages to the start of a score that will produce the A  (or 
Bb) drone notes without having to significantly modify the notation 
 

 
 
 
Export Bagpipe Audio will transpose a score up a semitone and use File >Export > Audio on the 
transposed score. You will need to create mp3 files as a separate step. 
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Bagpipe Notation Repair has an option to flip note stems (useful if you have entered notes using a 
stems down manuscript paper), causing an unstrument changes to an instrument with stems up, and 
then flipping the stems of all non-grace notes. The motivation for this is exaplained above. 
 
It also has another option to rebeam notes in a non-standard way for reels. It will beam together 
groups of 8th notes or dotted 8ths and 16ths that Sibelius  beams separately. 
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Appendix A: Ornament descriptions 
 
An ornament description, as used in several of the bagpipe plugins, is a string of letters (ABCDEFG) 
and octave designators (, and ') describing the pitches available for Great Highland Bagpipes. C 
represents C# and F represents F#, and all other pitches are the natural pitch. 
 
The notes G and A need octave designators. Use a following comma for low G and A (G, and A,), and a 
following single quote for high G and A (G' and A'). The full highland pipe scale would be shown as 
G,A,BCDEFG'A'.  G and A without an octave designator will not be recognized. 
 
The duration is by default 32nd notes (demisemiquavers). To change a note's duration place a 
multiplier number after the note. A 2 will double the duration, which will make a 32nd note a 16th, 
and a 4 will make the 32nd an 8th. 
 
So for, example, G'E4D describes a 32nd note high G followed by an 8th note E, then a 32nd note D. 
 
Since a plugin cannot show graphics for the ornaments (as some pipe-only programs do), you will 
need to identify the ornaments you want either by a name or the pitches use. So you might see "Full 
doubling G,:G'G,D" in a list, and it represents the 32nd notes High G, Low G, and D. 
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Appendix 2: Included files 
 
The following files are included in Bagpipes.zip: 

 
 
 
These include Manuscript Papers (yellow), plugins (green), house styles (magenta) and a PDF of a 
Word document (cyan). 
 
 
 
 


