The Shift Staff Spacing Plugin
Bob Zawalich August 6, 2023

What it does

Shift Staff Spacing adds a user-specified amount of spacing to each staff selected in a passage
selection. It does not process hidden staves. A positive spacing number moves the staves down, a
negative spacing moves the selected staves up.

The purpose of the plugin is to let you change a block of staves to have the same staff spacing.

You will likely more often want to use Staff Optimization, or Reset Spacing Above/Below Staff, or to
adjust stave spacing manually, but in certain cases, typically large scores with lots of staves, this
plugin may be useful.

This plugin is dedicated to Ilkay Bora Oder.

It requires Sibelius Ultimate version 2020.3 or later.

Shift Staff Spacing - Version 01.07.06 - by Bob Zawalich

Adjusts the distance between staves for all staves in a passage selection in the range of the selected bars.

Spacing can be spaces, mm, inches, or points. The spacing is added to or subtracted from the current line spacing of each
selected staff.

You may not get the spacing you specified, especially if the score is justified. Help (?) has suggestions for getting your desired
spacing. View> Staff Ruler, and set its units in File>Preferences>Other to see the results.

Spacing to add to selected staves: Engraving Rules settings

‘ 1| ** Default staff spacing: 6 spaces
spaces ** Staff Justification %: 0
mc:?\es Set Justification Percentage to 0 to always justify, to 100 to never justify
points [ Set Staff Justification Percentage: 0 %

® Use Relative Move commands Toggle staff ruler visibility

O Use Absolute Move commands Reset spacing for selected staves
[ ] Do not show this dialog (this Sibelius session) I ? ] Cancel | 0K
How it works

e The plugin runs one or more Sibelius Move Staff commands on each selected staff. The “a lot”
commands move the staff by 1 space, and the “normal™ commands move in 1/8 space
increments, though there is a lot or rounding involved with the “normal” commands, so it is
hard to be very precise.
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e The plugin automates what a user could do manually by dragging staves or using the Move
Staff commands on each selected staff.

e For various reasons, discussed below, you may not get the spacing you asked for.

You can usually run the plugin again with smaller adjustments to get closer to the spacing you
want.

Using the staff ruler

e Show the staff ruler (View>Rulers>Staff Rulers) to see what the current spacings are and
to see the spacing after the plugin is run.

e You can also toggle the visibility of the staff rulers by pressing the Toggle Staff Ruler
visibility button. This will close and then reopen the dialog.

e Change the units in the Staff Rulers to match the units chosen in this plugin. Go to
File>Preferences>Other to change units for the staff ruler.
Other

Rulers
Staff rulers:  spaces v

Selection and object rulers:  spaces v

An Example

Let’s say we want the violin 1 and 2 staves to have the same spacing, at a specific value. I have the staff
ruler set to show spacing in spaces. Note that I am not selecting the top violin 1 staff since I only want
to move the violin staves relative to the top violin staff.

This example has the engraving rules Staff Justification set to 100%, so no vertical page
justification is being done.

I used the Reset spacing for selected staves button so the staves would start at the same spacing,
as much as possible. At this time they are 6 spaces apart, which is the Engraving Rules default staff
spacing for this score (which the plugin dialog explains).
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I would like these staves to be 8.5 spaces apart, so I will need to add +2.5 spaces to these staves. When
I press OK, this is what I see. 2.6 spaces, have been added above each of the staves. The .1 space
difference is due to rounding error and is as close as the plugin can get to the desired spacing.
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Move Staff Commands

These Sibelius commands are called by this plugin.

Move staff down a lot (relative) / Select note in staff below
Move staff down (relative)

Move staff up a lot (absolute)

Move staff up (absolute) / Select note in previous voice

The plugin uses the “a lot” commands as much as possible, to move by full spaces. For spacing
smaller than a unit, it will call the normal commands as many times as needed to get close to the
desired spacing.

The “a lot” commands move 1 space at a time. So to move 2.5 spaces in the example above, I called
Move staff down a lot (relative) twice.

Move staff down (relative) theoretically moves 1/8 of a space at a time, but there appears to be a
lot of rounding going on. In my testing it usually took about 5 calls to move a space, rather than the
advertised 8 times. Each call to Move staff down (relative) moves about 1/5 (or .2) spaces, so it
would be called either 2 or 3 times to reach .5. These calls are likely where the rounding error comes
in.

Options
e Spacing units
o By default, the plugin adds spacing in units of spaces, where a space is ¥4 of the staff
size.
o Ifyou have installed the most recent version of the plugin Convert Units To Spaces,
you will be able to specify spacing in units of mm, inches, or points as well as spaces.

e Relative vs Absolute commands
o A relative Move command moves the selected staff and all staves below it in the score.
This plugin uses relative commands by default.
o An absolute Move command moves only the selected staves. If you keep moving the staff
it will eventually overlap the staff below and stop moving.
o In this document, all the examples use relative spacing.

Resetting staff spacing

If you want to make a group of staves have the same spacing, you need to start with the staves having
a consistent spacing. Press Reset spacing for Selected staves to reset spacing above and below
each selected staff. This button will not close the dialog. You can press it, then drag the dialog out of
the way so you can see the resulting spacing before making additional changes.

Reset spacing for selected staves

? Cancel OK

F:\WORD DOCUMENTS\SIBELIUS PLUGINS\DESIGN AND ANALYSIS
DOCUMENTS\SHIFT STAFF SPACING PLUGIN.DOCX PAGE 4 AUGUST 6, 2023



Engraving Rules and staff justification

Vertical staff justification has a very significant effect on this plugin, and on moving staves in general.
There are settings for staff justification in Engraving Rules> Staves.

Hang onto your hat...

Justification

Justify staves when page is at least % full

Justify all staves of multi-staff instruments

[ Justify both staves of grand staff instruments

System spacings may be contracted to %

If Justify staves when page is at least xx% full is not set to 100%, the systems on a page will be
justified if the music on the page does not exceed the justification percentage. This means that the
bottom staff of the last system will be aligned with the staff margin, as set in Document Setup, as soon
as the contents of the page exceed the justification percentage. Typically, the bottom staff of a justified
system stays attached to the bottom of the page even if staff spacing changes.

If a page is justified, changing staff spacing will change the spacing of the staves within the system,
rather than taking space from outside the systems. If you have a justified page, it is likely that the
number of spaces you enter in the plugin will not be what appears in the score, since changes in
spacing are distributed throughout the system.

If Justify staves when page is set to is set to 100%, the page will never be justified. The
bottom staff will be wherever staff spacing puts it. If you increase staff spacing, the bottom staff will
move down,; if you reduce space staffing, it will move up.

If a page is not justified, changing the staff spacing will move the bottom staff on the page. If the
bottom staff moves enough that the page is now full enough to be justified, the bottom of the page
may move abruptly to the bottom of the page. Similarly, if you reduce the spaces so that page no
longer exceed the justification percentage, the bottom staff will abruptly pop up.

This can be disconcerting. It will happen when you move staves manually as well, but since the plugin
often moves several staves at once, it is more likely to cause a noticeable justification change.

If a page is not justified and you change staff spacing, you may move the bottom system to another
page, or bring in a system from the following page.

You can change the Engraving Rules setting for the staff justification using the Set justification
edit box.
¢ Set justification percentage edit box
o The value in the edit box defaults to the current justification percentage from
Engraving Rules the first time the plugin is run in a session.
o Click the checkbox to be able to change the percentage.
o Changing the staff justification will change it for the entire score.
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More Examples

Non Justified scores

The earlier example in this document showed a non-justified score, where 2.5 spaces were added to 3
staves that started at 6 spaces apart, and they ended up 8.6 spaces apart, which is as close to 8.5 as the
plugin could come due to rounding. This works well because there was space below the bottom staff
and the added spacing can come out of that space, leaving the spacing of the staves below the staff
that was moved untouched.

With non-justified scores, there are a whole set of problems that may occur when the spacing is added
or removed.

e Adding space could force a previously unjustified system to be justified, especially if the default
justification percentage is the default of 65%. If the system justifies, the spacing between all the
staves in the system will become larger, so the system will fill the page.

e Adding space could force a system that followed the changed system to move to another page.
This may or may not make the processed system become justified, which will change the
spacing between all the staves in the system.

e Similar changes can occur when spacing is made smaller. A justified system may now be below
the justification percentage, and it will close up, changing the spacing between may other
staves. Reducing the size of the system may also mean that a system on the following page may
now fit on this page, and again, staff spacing may change.

Justified scores

Below is the first page of a justified score

To start with I want to make the spacing consistent. We could go to Layout>Reset Space Above/
Below to accomplish this or run the plugin and use the Reset Spacing for selected staves button
in the plugin.

In this score, the default staff spacing in Engraving Rules is 6 spaces. However, since the page is
justified, it fills the page and extra space is distributed among the existing staves when Reset Staff
Spacing is done.

In my current example, after resetting the spaces, the majority of staves have 8.8 spaces between
them, rather than the default 6 spaces.
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Let’s say I want the selected staves to be 11 spaces apart. I would need to add 2.2 spaces to each staff
(11 — 8.8 = 2.2). In the plugin, I set the spacing value to 2.2, and the units to spaces.
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Huh? Why are the staves 10.5 units apart, rather than 11? This seems more than what rounding would
account for.

This score is justified. The bottom staff is aligned with the staff margin, and cannot go any lower.
Thus any changes to staff spacing will come out of the spacing between the existing staves. We noted
already that the staves were further apart than expected due to justification.

The plugin processes each staff separately. To add 2.2 spaces it will call Move staff down a lot
(relative) / Select note in staff below twice, which moves the staff 2 spaces, and Move staff
down (relative) once, which is as close as it can get to .2 spaces.
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Let us do the same spacing manually and note what is happening. This will do exactly what the plugin
is doing.

I start with spacing of 8.8 spaces and run Move staff down a lot (relative) twice, which
should add 2 spaces above the staff. It gives me 10.6 spaces, which is less than the expected
10.8 spaces. Running Move staff down (relative) once gives me 10.9 spaces, which is close
to 11. But note that the other staves that were 8.8 spaces apart are now mostly 8.6 spaces apart.
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Selecting the next staff below and running the same commands adds 2.2 spaces to a staff with
8.6 spaces above, and it ends up changing the 2 staves we moved to be 10.7, and the staves
following became 8.4. The 2.2 extra spaces comes out of the space between the justified staves,
and the spacing is reduced a little in each staff after the changes are made.
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3. Now I process the 31 staff and run the same commands. The space above all the staves we
moved is now 10.5, and the other staves are at 8.2.

!

) e = ] =
1 - r
‘ Miissig langsam, mit Andacht. =72
() 1, Iy
b : )
L pute [ R ] =
‘ Pespr. I 7l
105 Violin I
| Dt
2.3. Pult. ||y —2—=&
@ i
IC".:'
‘ - |
‘ 1. Pult. %t’ i
105 Violin T
‘ 0 1
: >
2.3. Pult. || P b—2—£ = =
ANAYg i3
T )
\
82
‘ e
» P s S-S B
rrae||BEP T s s S sy a1 I
. "r'l'\'i‘rf_l'f_f
| b S = |
9‘3 Viola pespr.
; \
7 - )
2 putt. || B
a‘:
‘, | | [
y T —— I v = m— —
1. Pult. ||I=E i."b’-‘ X ‘s Z - ‘5 - ='Ir -
= I T
\ L1
82 P
|
* Violoncello |y b2 ! T
~ - 7 RV T T T T

This is what the plugin produced, and this effect is inevitable with justified staves.

What if I ran the plugin again to see if I can get closer? It turns out that if I run the plugin again on all
3 staves with .5 spaces, I come up with the desired 11 spaces between the staves, and 8 spaces between
the other staves.
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So could I have run it from the start with 2.7 spaces (2.2 + .5), and get the same result? In this case, at
least, yes.
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Is there a formula you can use to make the adjustment automatically in the plugin? It may be possibly
to calculate the effect of moving, but the plugin does not actually know whether a page is actually
justified, nor does it know how much space is between the staves, so guessing and trying out different
amounts is likely as good as it will get.
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