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These are plugins that can modify colors that are explicitly assigned to Bar Objects, such as notes,
text, symbols, or lines, using Home>Edit>Color or a plugin. They will not affect Voice or Out-of-
range colors, or colors assigned in File>Preferences>Accessibility.

Color Enharmonic Pitches lets you assign specific colors, by name, to notes of a given pitch.

You can assign different colors to notes with enharmonic pitches, which are pitches that sound the
same but are written differently, such as F# and Gb. Its dialog looks like this:

Color Enharmonic Pitches

This plug-in allows you to specify a color for individual pitches, using separate colors for enharmonically equivalent pitches (such as F#/Gb). If a note in a chord
is colored, all notes in the chord will have the same color unless colored notehead styles are used. See help for more details.

Double sharps and flats can be one color, colored the same as an enharmonic pitch (Gx -> A), or colored the same as a single accidental (Gx -> G#).
Quartertones can be colored as the nearest flat or sharp.

If you select a color from the double/quartertone lists, all such notes will get the same color, regardless of pitch.

Cb Leave color as is v G# Leave color as is v Coloring transposing instruments:
c Leave color as is . Ab Leave color as is V ® Color written Fics
C# Leave color as is e A Leave color as is i O color Ectidindlpitcres
Db Leave color as is v A# Leave color as is , )
[[] Coler lyrics syllables matching notes
D Leave color as is v Bb Leave color as is i
D# Leave color as is = B Leave color as is i

~
Colored Notehead Styles

i z B# i v
Eb Leave color as is Leave color as is i e o
I - | o Sibelius 8.3
E Leave color as is e Double Sharps Same as enharmonic pitch
E# Leave color as is v Double Flats Same as enharmonic pitch =
Fb Leave color as is v
[F Leave color as is v 1/4 Sharp Quartertone Same as nearest semitone i
F# Leave color as is & 3/4 Sharp Quartertone Same as nearest semitone =
N Internal code changes
Gb Leave color as is v 1/4 Flat Quartertone Same as nearest semitone Allows Apply Named Color
to edit colors
G Leave color as is v 3/4 Flat Quartertone Same as nearest semitone
Clear All All Black Set to Defaults Save as Defaults Edit Colors...

Sharp = Flat Flat = Sharp Cancel
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Use Help... for additional details.

I was asked to allow Color Enharmonic Pitches to color lyrics associated with notes to be the
same color as their “associated” note. Lyrics are not actually assigned to a note, so coloring is done if
there is a note at the same bar and position within the bar as a lyric syllable. If there is a matching
multi-note chord, the highest note in the chord is used to color the lyric syllable. It can now produce
something like this:

f Anld the loy - al
. | | | | | |

o |
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¥ ; 1 & \ 1 1
Death s the phoe - nix’ nest And the loy - al

I was planning to only use this in a custom version of the plugin, since I did not think it would be
useful in general, but I was making some other changes, and thought it would be OK to leave it in. The
Color lyrics checkbox is off by default.

I also removed an option to use Colored Notehead Styles as of Sibelius 8.3, since that appeared to
be causing confusion. Colored Notehead Styles was a scheme I used before it was possible to have
individually colored notes in a chord. Using the normal coloring of notes is simpler and more general,
so I removed the option.

Color Enharmonic Pitches has the special ability of allowing you to specify the RGB (Red, Green,
Blue) values of each of its named colors, so you can set up a custom RGB to color-name map,
which associates a name with an RGB value. The mapping is done in the Edit Colors dialog:
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Edit Colors

Edit the RGB (Red, Green, Blue) values of the colors to be used in this plugin. Each color must be 3 decimal numbers between 0
and 255, separated by commas.

Use "Reset RGB values" to erase any changes and start over with the standard plugin RGB settings.

Color Name

Black

Red,Green,Blue

Color Name

Red,Green,Blue

0,0,0) Light slate gray 240,245,255
Blue 136,64,255 Medium blue 0,0,205
Brown 165,42,42 Medium green 0,198,50
Dark blue 1 0,0,139 Olive 224,180,0
Dark cyan 192,255,232 Orange 255,160,64
Dark green 0,100,0 Orange red 255,69,0
Dark magenta 128,00 Pink 255,192,148
Dark salmon 233,150,122 Purple 140,0,160
Gray 128,128,128 Red 255,0,0
Green 32,255,60 Tan 226,214,255
Indigo 75,0,130 Violet 238,130,238
Light blue 173,216,230 Yellow 255,208,128
Light green 144,238,144 White 255,255,255
Reset RGB values View “standard" RGB values Cancel

The values shown above are the “standard” RGB values my color plugins have been using. The button
Reset RGB values is a new feature to restore the standard RGB values if you end up trying to create
a new RGB to color-name map and things go wrong. This is comparable to Clear All in the main
dialog.

I also made some internal changes to the code in Color Enharmonic Pitches that allow other
plugins to call it and set up their own RGB to color-name maps.

The current color settings in the main dialog can now be saved across Sibelius sessions, along with the
default color settings and the RGB to color-name map. Settings are saved only if you choose OK
in the main dialog. Changes are not saved if you choose Cancel.

If you are changing settings and want them to be saved, always use OK in the main
dialog, even if you don’t want to change the score. Use Undo when the plugin ends if you did not
want to change the score.
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Pitch-Color mapping in Color Enharmonic Pitches (not new but not documented)

You can assign a color to any pitches (in all octaves) you choose, including using different colors for
enharmonic notes which sound the same but are spelled differently, such as F# and Gb. This is the
Pitch to color-name map (as opposed to the RGB to color-name map set up in Edit Colors).

Previously, after you set up a Pitch to color-name map in the main dialog its settings would be
preserved only for the current Sibelius session. I have now changed the plugins so the colors chosen in
the main dialog will be saved to the Plugins Preferences file so these colors will be restored the
next time you run the plugin, even after closing and restarting Sibelius.

If you like your map, but would like to tinker with it some, you can save an extra copy of the current
map by pressing Save as Defaults. I recommend doing this after you finish setting up your map, so
you have an easy way to get back something you liked. To restore the map you saved with Save as
Defaults, press Set to Defaults.

You can also set the map to make all pitches Black (All Black) or reset all pitches to Leave color as
is (Clear All).

Color Enharmonic Pitches - Version 03.52.30 - by Bob Zawalich

This plug-in allows you to specify a color for individual pitches, using separate colors for enharmonically equivalent pitches (such as F#/Gb). If a note in a chord
is colored, all notes in the chord will have the same color unless colored notehead styles are used. See help for more details.
Double sharps and flats can be one color, colored the same as an enharmonic pitch (Gx -> A), or colored the same as a single accidental (Gx -> G#).
Quartertones can be colored as the nearest flat or sharp.
If you select a color from the double/quartertone lists, all such notes will get the same color, regardless of pitch.
Cb Orange red v G# Pink v Coloring transposing instruments:
@ Red o Ab Dark magenta o @® Color written pitches
C# Purple v A Dark green o QO Color sounding pitches
Do Violet - A Orange - (] Color lyrics syllables matching notes
D Medium green v Bb Dark salmon A
D# Gray v B Medium blue v
Eb Dark cyan v B# Olive P
E Light blue ¥ Double Sharps Same as enharmonic pitch v
E# Yellow v Double Flats Same as enharmonic pitch v
Fb Tan 7
F Brown ¥ 1/4 Sharp Quartertone Same as nearest semitone v
F# Dark blue v 3/4 Sharp Quartertone Same as nearest semitone v
Gb Light slate gray i 1/4 Flat Quartertone Same as nearest semitone N2
G Light green ¥ 3/4 Flat Quartertone Same as nearest semitone ¥
Clear All All Black Set to Defaults Save as Defaults Edit Colors... Help...
Sharp = Flat Flat = Sharp Cancel OK
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Apply Named Color

Apply Named Color lets you assign a color, using a name rather than an RGB value, to any selected
Bar Objects. It also is the only way that a user can change the Opacity/ translucency of colored
objects.

I redesigned the Apply Named Color dialog so that all the colors available are visible at once in a
tall list box. The colors names were previously in a drop-down list box, which was more compact but
not as convenient.

Apply Named Color-Redesign - Version 01.13.00 - by Bob Zawalich

Apply color to selected objects

Black This plug-in changes the color of all selected objects. You can remove any coloring by
Blue setting the named color to Black.

Brown

Dark blue Opacity, or Color Alpha Channel, is a measure of transparency, going from 0

Dark cyan (transparent) to the default 255 (opaque). Here we scale it as a percentage from 0 to
Dark green 100. It is only available in Sibelius 8.3 or later.

Dark magenta

Dark salmon You can set and trace the color and opacity values of most selected objects. For

Gray graphics, use Adjust Color in Notation > Graphics.

Green Edit RGB colors if current
Indigo version of Color
Light blue Modify opacity percentage (0 - 100) Enharmonic Pitches is

EVETELIS

Light green

Light slate gray %
Medium blue
Medium green
Olive

Orange
Orange red
Pink

Purple

Red

Tan

Violet

Yellow

White

Trace color and opacity Edit Colors... Help...

] Trace Results Cancel oK

All available colorsare now
visible in large list box

The other change to Apply Named Color is that you can now change the RGB color values used for
each named color. This calls the plugin Color Enharmonic Pitches to do the RGB mapping, so the
button is disabled unless the current version of Color Enharmonic Pitches is installed. Changing
the RGB values is tedious and finicky, but some have found it to be useful.

The standard plugin color mapping is described in the Apply Named Color Help dialog, and in the
Edit Colors dialog;:
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Apply Named Color Help

These are the *default* RGB (Red, Green, Blue) values and combined decimal color values for the named colors used in this plugin
(values found at http://www.tayloredmktg.com/rgb/#PI and http://www.webdesigns2000.com/WebPage1/colortest140.htm)
(corresponding to the values in Sibelius's Edit > Color command).

These colors correspond to the colors used in the pitch spectrum, plus black and gray and some additional colors.

RGB values may be edited using Edit Colors, which calls code in the plugin Color Enharmonic Pitches. The edited colors in each
plugin are independent. Changing colors in one plugin does not affect the other.

Use Edit Colors to see the current RGB values.
RGB Value Decimal Name

ROO0 GOOO BOOO 00000000 Black

ROO0 GO0OO B255 00000255 Blue

R165 G042 B042 10824234 Brown

ROO0 GO0O B139 00000139 Dark blue
ROO0 G139 B139 00035723 Dark cyan
ROO0 G100 BOOO 00025600 Dark green
R139 G000 B139 09109643 Dark magenta
R233 G150 B122 15308410 Dark salmon
R128 G128 B128 08421504 Gray

RO0O0 G128 BOOO 00032768 Green

RO75 G000 B130 04915330 Indigo

R173 G216 B230 11393254 Light blue
R144 G238 B144 09498256 Light green
R119 G136 B153 07833753 Light slate gray
ROO0 GO0OO B205 00000205 Medium blue
ROO0 G198 BO50 00050738 Medium green
R128 G128 BO0O 08421376 Olive

R255 G165 BO0O 16753920 Orange

R255 G069 BO0O 16729344 Orange red
R255 G192 B203 16761035 Pink

R160 G032 B240 10494192 Purple

R255 G000 BOOO 16711680 Red

R210 G180 B140 13808780 Tan

R238 G130 B238 15631086 Violet

R255 G255 B0O0O 16776960 Yellow

Though Edit Colors in Apply Named Color calls code in the plugin Color Enharmonic
Pitches, the edited colors in each plugin are independent. Changing colors in one plugin does not
affect the other.
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Color Picker

Color picker was originally designed to let you select a colored object and save the RGB values of that
object so you could apply that color to other objects. As the dialog explains, this a a 2-step process:
e Select a colored object and run the plugin, choosing Pick Color to save the RGB values.
e Select objects you want to color, run the plugin, choose a color to apply, and choose Apply
Color.

This can be useful if you had used Home>Edit Color to choose a custom color and did not
remember which RGB values you used.

Color Picker - Version 01.05.20 - by Bob Zawalich

This plugin has 2 distinct steps:
1. Select an object with the color you want to copy. Run the plugin and choose "Pick Color".
2. Select the objects you want colored. Run the plugin, select a picked color, and choose “Apply Color".

RGB combinations that are not given specific names by this plugin are listed as "no name". Voice and out-of-range
colors are not recognized. The colors picked are remembered across Sibelius sessions.

Color that could be applied: Black: R(0)G(0)B(0) 0 (#0) RV

Rename colors... * Apply Color

Color that could be picked: | Black: R(0)G(0)B(0) 0 (#0)

Pick Color

Trace picked color values Cancel

I decided that it could be useful to know the RGB values of specific colors when editing colors in the 2
plugins already discussed, so I added a Trace picked color values button here to display the color
name and RGB values for colors for which you had pressed Pick Color.

(@3] Plug-in Trace = O X

no name: R(179)G(47)B(255) (179,47,255) 11743231 (#BSZFFF)'

[] Trace function calls Clear Close

It then occurred to me that it could be useful to have multiple picked colors rather than the single
color it had, so I changed the Color that could be applied field from a text object to a drop-down
listbox, which could store multiple colors. I then changed the plugin so the list of picked colors would
be saved across Sibelius sessions. This would let you build up a library of custom colors you could use
in multiple scores.
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I have assigned color names in other plugins to a relatively small number of RGB values, and
unnamed colors are usually identified only by their RGB color. This was not so bad if the color only
existed when the plugin had just been run, but I thought it was not good to have a bunch of unnamed

colors in the Color Picker list.

I added a Rename Picked Colors button, which lets you add or change the names used to identify
any of the colors in the Color that could be applied list. You can only rename a color after you

have chosen it with Pick Color.

Color Picker - Rename Color - Version 01.05.20 - by Bob Zawalich

Black: R(O)G(0)B(0) O (#0)

Pink: R(255)G(192)B(203) 16761035 (#FFCOCB)

Medium Green: R(0)G(198)B(50) 50738 (#C632)

Brown: R(165)G(42)B(42) 10824234 (#A52A2A)

Dark Green: R(0)G(100)B(0) 25600 (#6400)

Yellow: R(255)G(255)B(0) 16776960 (#FFFF00)

Red: R(255)G(0)B(0) 16711680 (#FF0000)

Custom Pinkish: R(86)G(74)B(255) 5655295 (#564AFF)

Bob Custom Color 1: R(255)G(170)B(127) 16755327 (#FFAATF)
: FF8%)

I no name: R(179)G(47)B(255) 11743231 (#B32FFF)

ﬁ"Pinky purple

| Replace Color Name

You can change the name used to identify any of the colors in
the listbox. A color name should avoid most punctuation, and
you will be warned if the name you choose cannot be used.
You can replace the name of any colors, even those with
standard names, so you can have a map of colors with both
custom RGB values and custom names. If you close the dialog
with OK, any changes you make will be saved. If you use
Cancel, changes will be discarded.

Cancel OK

I could imagine this list being used similarly to the way the color lists in Apply Named Color are
used, to provide a consistent color naming and RGB color-name mapping for colors in multiple

Scores.

The color names used in Color Enharmonic Notes and Apply Named Color are the same,
though the RGB values associated with the names can be different. The color map and color names
used in Color Picker is completely independent of the other 2 plugins.

All these plugins can be installed in Sibelius 7 or later using File>Plug-ins>Install Plug-ins.
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Appendix: Which dialog settings are saved and where?

Each of these plugins save dialog settings to the Plugin Preferences data file
SibeliusPluginPreferences.dat. The Preferences data file is usually intended to save settings as a
convenience for the next time the plugin is run, but for these plugins, the saved settings take a lot of
work to set up and are hard to reproduce. The Plugin Preferences file can be fragile, so it should at
least be backed up when settings are changed.

I recommend taking screen shots of dialogs when they are set up the way you want them, and you can
also make backup copies of SibeliusPluginPreferences.dat by installing and running the plugin
Backup Plugin Preferences. It will make a copy of the current file in the same subfolder as the
original file and renames the copy so the current data and time are included, and the extension is
.bak. Here is the dialog that appears when you run the plugin:

Backup Plugin Preferences - Results... - Version 010500 - by Bob Zawalich

Success - The Plugin Preferences file was backed up to

C:\Users\Robert\AppData\Roaming\Avid\Sibelius\SibeliusPluginPreferences 2024-1-10_16h29m58s.bak

O Open file browser...

) ‘ Close
Date time suffix.
Bring up the file browser. Use the name of the file to tell

where to look. The name will also be written to the
plugin trace window,

Open File Browser might be useful if you want to look at the file in context. The mechanism
plugins use to put up a file browser is pretty good at starting in the desired folder. The file name will
also be written out to the plugin Trace window when you run the plugin,

Success - The Plugin Preferences file was backed up to:
(C:\Users\Robert\AppData\Roaming\Avid\Sibelius\SibeliusPluginPreferences_2024-1-10_16h29m58s.bak)

You can go there later and copy the full path name it you want to use it in a browser. Ignore the
parentheses at the start and end of the name in the traced output.
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The Preferences plugin

You can run the shipping plugin Preferences to see what is being saved to
SibeliusPluginPreferences.dat, and even edit the data if you are both daring and careful. I
recommend backing up the Plugin Preferences file with Backup Plugin Preferences before doing

any editing.

Preferences Editor

Plug-in: Scope:

Run Plugins By Name * Global variables *
Color Enharmonic Pitches
BackupPlugin

Color Picker

Apply Named Color

Fill Selection With Slash Notes

Click here to choose a plugin to
examine

* List of variables declared as local *

Mostly ignore this

Keys and Arrays:
E = Light blue. A
Eit = Yellow. See what is saved. If you
Fb = Tan. select an array then then
F = Brown. choose Edit you can see (and
. change) the entries in the
F# = Dark blue. :

array.
Gb = Light slate gray.
G = Light green.

G# = Pink.

Double# = Same as enharmonic pitch.

Doubleb = Same as enharmonic pitch.

14SharpQuartertone = Same as nearest semitone.

34SharpQuartertone = Same as nearest semitone.

14FlatQuartertone = Same as nearest semitone.

34FlatQuartertone = Same as nearest semitone.

fColoredNoteheads = 0.

fColorForTransposing = 1.

fColorForNonTransposing = 0.

fColorLyrics = 0.

RGBList [27] = -1.0,0,0.0,0,2... 165/4... 0,0,1... 0,139... 0,100... 139,0... 233,1...
CurrentColorList [21] = Orang... Red. Purpl... Viole... Mediu... Gray. Dark ......
DefaultColorList [21] = Orang... Red. Purpl... Viole... Mediu... Gray. Dark ... ...

v

Delete Rename Delete

New Copy New

Rename

Copy

Help

Delete Rename
Choose this unless you
New Copy reallyu want to edit some
settings.
Exit Without Saving Save to Disk
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